Liveness NPM package update to ensure compatibility with the latest Chromium browser versions
Completed
The scheduled maintenance has been completed.
Posted Sep 16, 2025 - 17:30 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 17:30 AEST
Scheduled
Google has started rolling out the latest Chrome update version 140. To make sure everything continues to run smoothly, we’ll be updating the liveness packages across IDVerse Enterprise and IDkit instances.
This will be done gradually over the next week, and we don’t anticipate any disruption during the process.
No action is required on your side.
If you, or your customers, experience any issues with liveness, please try using another browser such as Firefox, Safari, or Samsung Internet. If the issue persists, reach out to our Support team through the Support Centre or by email.
Posted Sep 09, 2025 - 17:18 AEST
This scheduled maintenance affected: Australia (IDKit Enterprise Platform, IDKit Platform), Canada (IDKit Enterprise), United Kingdom (IDKit Enterprise Platform, IDKit Platform), and USA (IDKit Enterprise Platform, IDKit Platform).